We are advising all of our followers to upgrade their WordPress versions to the newly released 4.0.1.

Automattic released the new version when serious security issues were brought to it’s attention in the core code.

This is a rarity as the WordPress core is usually very stable.  The last reported core issue was in v2.3.2 back in 2008 (ref: http://bit.ly/1yLBUIX)

They announced the release in a post on the WordPress.org website detailing the issues and the fixes they put in place.

WordPress 4.1 is due for release on December 10th but please do not wait.  Update your WordPress version now otherwise you’re website could potentially get hacked.  This is a critical update.